Friday, December 11, 2009

Synergy between PowerBook G4 and Ubuntu Server 8.04

I've just installing and configuring Synergy (a program that enables you to share one keyboard and one mouse for use in multiple machine) between my Ubuntu Box and Powerbook G4. Actually, it is so simple, all you need to do is have a synergy installed on both machines.

1. Ubuntu:
$ sudo apt-get install synergy
2. Powerbook:
On Powerbook, there is a client called QuickSynergy, but I have a random disconnect problem using it, so I'd rather suggest you to installing Macports, and do this:
$ sudo port install synergy

Choose either one as your server and the other as a client.

*SERVER
In your server, you create synergy.conf, containing this:
section: screens
            ubuntubox:
            powerbook:
end
section: links
            ubuntubox:
                        right = powerbook
            powerbook:
                        left = ubuntubox
end
Then, still in your server:
$ synergys -f --config synergy.conf
And, if it run properly, you can see it in messages that show up, do this:
$ mv synergy.conf ~/.synergy.conf
Then, next time you want to execute your synergy server, just do this:
$ synergys
*CLIENT
And from your client, do this:
$ synergyc -f [your-server-ip-address]
I'm sure you already can have your mouse running around between your two machines :) Enjoy!

Tuesday, November 24, 2009

Custom Ringtone for Grandstream GXP-1200 IP Phone

As you can see on my previous review for this Grandstream GXP-1200 IP Phone, this fabulous IP Phone has feature to setup custom ringtone. In this post, I'll show you how to create it, using Ubuntu Server 8.04. In order to make it smooth, you need to have these files:

1. WAV's files you want to use as your ringtone. Grandstream advice to use wav's files not more than 100 kb, and prefered not more than 70 kb
2. Grandstream Ringtone Generator, which you can download here and available for Linux or Windows platform
3. TFTP server (see here to set your own) to upload any files to your IP Phone

If you already have the wav's files:
1. download Grandstream Ringtone Generator for Linux and extract it on separate folder.
# unzip -e Linux-Music-Ring-Tone-GEN.zip
# mv sox.linux sox
# chmod +x sox
I'm assuming you already put all your wav's files in the same folder as the generator, do these:
# ./sox ring1.wav ring1.ring
# mv ring1.ring ring1.bin
Then you can put your ring1.bin on your TFTP Server base directory.

1. Access your IP Phone from web browser (e.g http://192.168.xx.xx), and use password: admin.
2. Go to 'Advanced Settings'
3. On 'Firmware Upgrade and Positioning', change it to TFTP
Firmware Server Path: [your TFTP server IP address]
Config Server Path: /
4. Update and Reboot

After reboot, your IP phone downloading the ring1.bin you already put on your TFTP base directory. On the IP Phone:

1. Press 'Menu' --> 'Preference' --> 'Ring Tone'

And you're done! Enjoy your new ringtone :)

Build TFTP Server on Ubuntu Server

If you work with hardware a lot, like upgrading firmware, etc. you'll need a TFTP server for yourself, instead of using internet TFTP server. Why? Because you'll have stable connection and it a must to have stable connection when you upgrading a firmware. Below are steps for building TFTP Server using TFTPD on Ubuntu Server 8.04:

1. installing TFTPD
# sudo apt-get install xinetd tftpd tftp
2. Create /etc/xinetd.d/tftp, then put this:
service tftp
{
protocol        = udp
port            = 69
socket_type     = dgram
wait            = yes
user            = nobody
server          = /usr/sbin/in.tftpd
server_args     = /tftpboot
disable         = no 
}
3. Make /tftpboot
# sudo mkdir /tftpboot
# sudo chmod -R 777 /tftpboot
# sudo chown -R nobody /tftpboot
4. Restart TFTPD
# sudo /etc/init.d/xinetd.restart
Now you can put all the files (e.g. firmware files) in /tftpboot directory. And setup your hardware to point to your machine IP as your TFTP server.

Thursday, November 12, 2009

Beginner's Lab #3 - CISCO Switch and Router







 Objective of this Lab, is to make PC A be able to ping PC B and vice versa

1. Set IP and Subnet in each PC, according to the image above
2. On Switch:
> enable
# configure terminal
(config)# interface FastEthernet 1/1
(config-if)# switchport mode access
(config-if)# switchport access vlan 2
(config-if)# no shutdown

(config-if)# interface FastEthernet 1/24
(config-if)# switchport mode access
(config-if)# switchport access vlan 3
(config-if)# no shutdown

(config-if)# interface FastEthernet 1/2
(config-if)# switchport mode trunk
(config-if)# switchport trunk allowed vlan 2
(config-if)# switchport trunk allowed vlan add 3
(config-if)# no shutdown
(config-if)# (*press ctrl-z)
# write
3. On Router:
> enable
# configure terminal
(config)# interface Ethernet 0
(config-if)# no shutdown

(config-if)# interface Ethernet 0.1
(config-if)# encapsulation dot 1Q 2
(config-if)# ip address 192.168.1.1 255.255.255.252

(config-if)# interface Ethernet 0.2
(config-if)# encapsulation dot 1Q 3
(config-if)# ip address 192.168.1.5 255.255.255.252
(config-if)# (*press ctrl-z)
# write
Shouldn't be any problem, I hope :)

Beginner's Lab #2 - CISCO Switch






 Objective of this lab, is to make PC A/B be able to do telnet to switch

1. Set IP and Subnet in each PC, according to the image above
2. On switch:
 > ena
# configure terminal
(config)# interface FastEthernet 1/1
(config-if)# switchport mode trunk                           //activating trunk mode for certain port
(config-if)# switchport trunk allowed vlan 2            //allow mentioned vlan on certain port
(config-if)# switchport trunk allowed vlan add 1     //add allowed vlan on certain port
(config-if)# no shutdown

(config-if)# interface FastEthernet 1/24
(config-if)# switchport mode trunk
(config-if)# switchport trunk allowed vlan 2
(config-if)# switchport trunk allowed vlan add 1
(config-if)# no shutdown

(config-if)# interface vlan1
(config-if)# ip address 192.168.1.10 255.255.255.0

(config-if)# exit
(config)# line vty 0 4                                        //setting up telnet access
(config-line)# login
(config-line)# password [pass]
(config-line)# (*press ctrl-z)
# write
that's it.. try your configuration :)

Beginner's Lab #1 - CISCO Switch





Objective of this Lab, is to make PC A be able to ping PC B and vice versa

1. Set IP and Subnet in each PC, according to the image above
2. On switch:
> ena
# configure terminal
(config)# interface FastEthernet 1/1
(config-if)# switchport mode access     //activating access mode for certain port
(config-if)# switchport access vlan 2    //from 1 to 2000
(config-if)# no shutdown                       //activating certain port

(config-if)# interface FastEthernet 1/24
(config-if)# switchport mode access
(config-if)# switchport access vlan 2
(config-if)# no shutdown
(config-if)# (*press ctrl-z)
# write                                                   //save your configuration
you should be able to ping from PC A to PC B and vice versa, then :)

Friday, October 30, 2009

Installing Nagios 3 on Ubuntu Server 9.10

Follow these steps to installing Nagios 3 on Ubuntu 9.10 Karmic Koala Server Edition:
# sudo apt-get install nagios3
Just follow on-screen instruction. After that, setting up user to access the Nagios web interface:
# sudo htpasswd -c htpasswd.users nagios
   New password:
   Re-type new password:
   Adding password for user nagios
Open up http://localhost/nagios3, enter your username and password you've just created. For configuring the services and hosts you want to monitor, go to /etc/nagios3/conf.d directory and you will see several base file for nagios (.cfg). For now, Nagios 3 is already running and what you have to do next.. configuring your host file for monitoring purposes.

OpenVPN on PocketPC

I'm using OpenVPN client on my Palm Treo Pro to connect to OpenVPN server at my office. After connecting I can access my PC and doing some work stuffs. All you need is .ovpn file and several key files (simply asked your OpenVPN server Admin to generate them for you)

What important is how you configure your .ovpn file. You can see below my sample-config. Please note that I'm using two backslashes, instead of one, to mention location of config folder and files.

* sample config of my .ovpn file:

     client
     port 1194
     dev tun
     proto udp
     remote [ your openVPN server]
     resolv-retry infinite
     nobind
     persist-key
     persist-tun
     redirect-gateway def1

     ca "\\Program Files\\OpenVPN\\config\\ca.crt"
     cert "\\Program Files\\OpenVPN\\config\\[yourfile].crt"
     key "\\Program Files\\OpenVPN\\config\\[yourfile].key"
     tls-auth "\\Program Files\\OpenVPN\\config\\tls-auth.key" 1
     cipher AES-256-CBC
     ns-cert-type server
     comp-lzo
     verb  3

Another files you must provide is the key files. Put them (.ovpn and key files) in the same directory, usually under config folder on installation directory.

This config already tested and works perfectly :)

Upgrade From Ubuntu 9.04 to 9.10 Server Edition

Ubuntu 9.10 Karmic Koala Server Edition is available for download, but if you already used Ubuntu 9.04 Jaunty Jackalope Server Edition, you can do these steps to upgrade to 9.10. Here are what you have to do:

1. install update-manager-core package (in case it's not installed yet)
2. edit /etc/update-manager/release-upgrades
Prompt=normal
3. # sudo do-release-upgrade -d
4. wait till upgrade process succeed


And if you have Desktop System, you can do these:

1. Press Alt+F2 on your GUI
2. Type in "update-manager -d" (without quotes)
3. Update Manger should open up, and you can see "New distribution release '9.10' is available"
4. Press the 'Upgrade' button, and wait till upgrade process succeed

Thursday, October 29, 2009

Dual Boot-ing Windows 7 and Ubuntu Jaunty 9.04 Server Edition

I just succesfully implementing dual boot Windows 7 and Ubuntu Jaunty, using Windows 7 Bootloader, with the help of awesome application called EasyBCD. My first trial was using GRUB Bootloader (install to MBR), with the result "BOOTMGR is missing". Apparently my GRUB installation on MBR, not just failed, but also destroyed Windows 7 Bootloader.

Here is my disk partition mapping, my harddisk size is 80GB:
# Primary partition
/dev/sda1 100mb - automatically created with Windows 7 installation
/dev/sda2 32gb - Windows 7 installation

# Logical partition - Ubuntu
/dev/sda5 100mb - boot
/dev/sda6 2gb - swap
/dev/sda7 10gb - root
/dev/sda8 32gb - home

Before installing Windows, I move the GRUB installation from MBR to my root partition. This way, I can switch between Windows 7 bootloader and GRUB bootloader.

After installing Windows 7, download and install EasyBCD, run it, then go to add/remove Entries:


image courtesy to Neosmart

In Drive, choose your root partition, click 'Add Entry' button, then Save. That's it! Restart your computer, and you'll get Bootloader to choose your Operating System :)

Thursday, October 22, 2009

Installing Zenoss on Ubuntu Jaunty 9.04 Server Edition

Zenoss is open source network infrastructure software. Here is how I installed it on my Ubuntu Jaunty 9.04 Server Edition. First, make sure you do the following:

# sudo apt-get install build-essential autoconf swig
# sudo apt-get install libmysqlclients15-dev
# sudo apt-get install python-dev


# sudo vi /etc/apt/sources.list
  • ## zenoss-ubuntu
  • deb http://dev.zenoss.org/deb main stable
# sudo apt-get update
# sudo apt-get install zenoss-stack
# sudo /etc/init.d/zenoss-stack start

After the setting-up is done, you can access 1st time setup wizard by pointing your web browser url to http://localhost:8080

Guidelines for Access List

These are guidelines for creating access list in Cisco Router:

a. use text editor
b. acl proccessed top-down, place more specific tests and tests that will true frequently - at the beginning of the access-list
c. only "named acl" allow removal individual statements, not reordering
d. if you want to reordering and remove "numbered acl", you must remove whole list & recreate
e. all acl end with an implicit deny all statement
f. place "extended acl" close to the source, place "standard acl" close to the destination

How to Check 3rd Party Connection (Wireless) on Cisco Switch

This is what we can do to check 3rd party connection (wireless) on Cisco Switch:
On Cisco switch, execute this:
SWITCH> show vlan id [vlan id]

- to view which ports using this vlan, find out port with description "trunk to wireless provider"

SWITCH> show mac-address-table | i [vlan id]

- to see whether the port with description "trunk to wireless provider" shown up or not, if it doesn't, something is wrong, then :)

Easy Way to Wildcard counting

If you are a network engineer and deal a lot with Cisco router configuration, this short post might help you, I hope :)

wildcard = host - 1
host = 2^(32-prefix)

For example:
/28 --> prefix 28
host = 2^(32-28)
host = 2^4
host = 16

wildcard = 16 - 1
wildcard = 15

So wildcard masking for: 172.30.16.0/28 --> 172.30.16.0  0.0.0.15

Exporting and Importing MySQL Database

1. Export
# mysqldump -u [username] -p [database-name] > [database-name].sql
2. Import
# mysqladmin -u [username] -p create [database-name]
# mysql [database-name] < [database-name].sql

Cisco Router configuration for NetFlow

Cisco router config for NetFlow

On user interface:

# ip route-cache flow
exit, then in global configuration mode:
# ip flow-export destination [host IP] [port] --> usually 9996
# ip flow-export source loopback 0
# ip flow-export version 5
And you can execute this command to show if your configuration works:
# sh ip cache flow
# sh ip flow export

snmpwalk and netcat

1. snmpwalk

from Linux/ UNIX gateway:
# snmpwalk -v [1|2c|3] -c [COMMUNITY] [IP Router] | grep -i [Port]
from router:
# show snmp mib Ifmib ifindex [interface] [port]

2. netcat

I use it to retrieve detail information about AS Number, Country, etc. based on IP address:

# netcat whois.cymru.com 43 < [filename-original].txt > [filename-output].txt
The file is batch file containing more than 1 IP address, and this is the format for the file:
a. should be save in MS-DOS text format
b. in the body file:
begin
verbose
[IP address 1]
[IP address 2]
[IP address 3]
and so on..
..
..
end
That will do. The proccess takes a few minutes depending on how much IP address in the file. After completing, you can take a look at the file and you'll be surprise :)

Ccache - Caching Compilation in Gentoo Linux

Ccache is a fast compiler cache. To install it, do this:

# emerge ccache

For 1st install:

# ccache -M 2G

Then:

# nano -w /etc/make.conf
  • FEATURES="ccache"
  • CCACHE_SIZE="2G"
  • CCACHE_DIR="/var/temp/ccache"
# PATH="/usr/lib/ccache/bin:/opt/bin:${PATH}"

To view ccache statistics:

# CCACHE_DIR="/var/temp/ccache" ccache -s

Wednesday, October 21, 2009

TTYtter - My Favourite Twitter client

@ttytter, developed by Floodgap is my favourite twitter client. Despite of its minimalist look (CLI apps, text-based running on terminal), I can use it to run on many platform, including on my Palm Treo Pro. On Linux/Unix and Mac, you just need to do this:

1. download it from here
2. on the directory where you keep the download:
# mv ttytter.txt ttytter
# chmod +x ttytter
3. then you can run it by executing:
# ./ttytter
or
# ./ttytter -user=[username]:[password] -vcheck
If you are Windows user, you can do telnet/ SSH to your Linux/ UNIX machine, or if you don't have any, you can register to public access UNIX server like SDF and running ttytter from there. Same thing if you want to use your mobile phone. From my Palm Treo Pro which running Windows Mobile, I just need to install SSH client like PocketPutty, and do the rest like you do at Windows PC. That also applies to another mobile/ pda phone using any OS, as long as they have telnet/ SSH client installed.

Some simple command is:
1. type directly to post status update
2. D [username] to send direct message
3. /re [post number] to reply
4. /rt [post number] to retweet

5. /re to list @[yourusername]
6. /again to refresh your timeline
7. /dmagain to show your DM

For complete operational command, you can look here.

And for additional group support, you can take a look at my friend's blog (@vkoser) here.

Tuesday, October 20, 2009

SnapIt - Simple Way Of Screen Capture

As an engineer, I work a lot using Asus eeePC 701 doing bandwidth test, capacity measuring, speed testing, etc. And I have to capture all the on screen results, for reporting. All this year I've been using old-manual way: print screen button, open image editor program (usually I used Microsoft Paint), paste and save. Can you imagine doing that with 7" screen? :) But I didn't feel much bother with it, since that's the only way I know, and slowly it became a habit.

But, since I've found this simple yet great program, it changes the way I work. Everything become soooo..simple. I mean it! It called SnapIt. After downloading and installing (small installation files), you can start your 14 days of fully-functional trial. Start the program, then you'll find a front-view camera icon on system tray:


Right-click on it, then it shows the menu:
 

choose the Properties menu, and you'll get this window:



You can choose the Hot key from regular Print Screen button, F10, F11 or F12. You can see that I prefer using 'Auto save image to folders' of my choice, and Jpeg as my Image Type. That's it! Can't find way more simple then this. Everytime I'd like to capture my work results, I just press Print Screen button, and my cursor change to big 'plus' symbol. Just hold your left mouse button, drag and choose whether it selected area, curent windows or the whole desktop.

Try it, I'm sure you'll like it :)

* Note: all images in this post are captured using SnapIt

Monday, October 19, 2009

Utilizing your old Palm Treo 650 :)

In this high-end gadget era, features like HSDPA, Wi-Fi, GPS, multitouch, etc. would be standard features that everybody would want to have on their devices. But for me, that won't matter. That's why I still keep my Palm Treo 650, which (as you might already knew) even don't have 3G, Wi-Fi, GPS nor multitouch :D

It's okay for me, just equipped it with unlimited data access, I set it up so it can be used as my working tool. My primary tool is pssh and CheckWWW, which I use a lot to do SSH to my UNIX server and doing things within its terminal. With CheckWWW you can do ping, whois, trace, lookup, finger, etc.

Another thing is setting up email with ChatterEmail, which actually can do "push email" with idle-imap technology. This idle-imap works by sending out small amount of data to mail server periodically, to check for new email, and if there is any, then ChatterEmail will executing request command and then retrieving the email. Almost no delay, just like push email, right? :)

And also Chatopus for my IM needs, you can see my post about integrating Nimbuzz account to Chatopus here. For web browser, you can use built-in Web from palm. Another choice would be Mini Opera and/ or Xiino.

For entertainment purposes, you can use AeroPlayer for local media files, simple, light and skinnable. Another multimedia player is PocketTunes and/ or CorePlayer which allow you to do streaming internet radio and watching YouTube, respectively. Another entertainment thing is games. I use LJP (aka. Little John PalmOS), an emulator to play from NES, SNES, Sega and many other old game console.

With DocsToGo, you'll be able to create new and/ or edit office documents (doc, xls, ppt) and read pdf files. It'll be some kind like e-book reader :)

And, for completing many activities with Palm Treo 650, I use CoLauncher. This amazing applications allows me to switch from an application to another without have to press Home button and back to default launcher before open another application. All you have to do is assigning one HardButton to execute CoLauncher, then press one letter or number, which you already setup before, to launch application assigned to it. So easy, just try it.. I'm sure you'll like it :)

That's for me :) How about you? Please share how you use your old Palm Treo 650.. Thanks!

Saturday, October 17, 2009

Reviewing Grandstream - IP Phone

This week I had a chance to try out two products from Grandstream, GXV3140 and GXP1200. I'll walk through it from a end user view :)

1. GXP1200
Regular-function IP Phone, setup and call :) This is how to setup this phone:
a. Press MENU button, go to Config menu and set IP parameter (static or DHCP, IP, subnet, gateway, DNS)
b. Press back button, then choose SIP menu, set which Account to activate, then fill in SIP User ID, Auth ID (basically it's the same for this two), SIP Password and SIP Transport, and Save
* a little note for this SIP Transport. I have to set the SIP transport to TCP, instead of regular UDP, to make my account registered *

Another way to setting up, after completing IP parameter, you can access it from web browser by typing http://[IP Address], with password: admin

This phone support up to 2 SIP Accounts, call waiting, caller ID, hold, transfer, conference and 3 custom ringtone you can create :)

Download the User Guide for GXP series here.

2. GXV3140
I could say that this is the kind of IP Phone I would like to have and use :))
Color LCD, switch screen (clock and account status on screen 1, RSS reader and stock info on screen 2, calendar and weather info on screen 3), IM, web browser, games, internet radio, picture viewer, multimedia player, screensaver with stunning picture and last but not least, a tetris game! LOL.. That's at least all the features I can mention.

For setting up this phone, I only can do it from web browser. So, after completing IP parameter, I open http://[IP Address] typing user/pass:
user: user
pass: 123 - for user access level (mostly only view configuration), or
user: admin
pass: admin - for admin access level (have to using this to configure)

The GUI is simple and clear. Support up to 3 SIP accounts, and you also can setup for weather update, RSS news, photo album (already support flickr, photobucket and phanfare geezz..), Last.fm account (for online music) and browser setting.

That's all for now, have to wandering around a little more :) oh, I forget to mention that this phone also have audio-video port, SD card reader, USB port and 2.5" audio port :D


RSS Reader and Stock Info

 
Calendar and Weather Info


Menu


Photo Album (Photobucket, Flickr, Phanfares)



Tetris Game :)

Tuesday, October 13, 2009

Internet Explorer on Linux

This is only for fun, don't expect to have a regular IE browser :) Only simple way to try:

# wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz
# tar -zxvf ies4linux-latest.tar.gz
# cd ies4linux-*
# ./ies4linux

Just follow through the wizard, and after installation is done, you can execute IE by typing:

# ~/bin/ie6

Monday, October 12, 2009

Install and Run Palm® Mojo™ SDK on Ubuntu

I just make the summary on how to installing Palm® Mojo™ SDK on Ubuntu (I'm using Jaunty 9.04 - server edition), you can see the full how-to here:


1. install Sun Java Runtime Environment (Sun JRE)
# sudo apt-get install sun-java6-jre

2. install VirtualBox 3.0
    a. Add the repository to /etc/apt/sources.list:
deb http://download.virtualbox.org/virtualbox/debian jaunty non-free
    b. Download and install public key for apt-secure: 
# wget -q http://download.virtualbox.org/virtualbox/debian/sun_vbox.asc -O- | sudo apt-key add -
    c. Refresh the repository and install Virtual box:
# sudo apt-get update && sudo apt-get install virtualbox-3.0
3. Installing the Palm® Mojo™ SDK
    a. Download the Linux® SDK,which consists of 2 packages:
    b. Installing:
# sudo dpkg -i palm-sdk_1.2.0-svn197576-sdk77-pho30_i386.deb
# sudo dpkg -i palm-novacom_0.3-svn196852-hud21_i386.deb
 4. Run the SDK
# palm-emulator
The emulator makes me want to have webOS devices, more than ever :)

Thursday, October 8, 2009

Installing Mozilla Firefox on Ubuntu

Mozilla Firefox would be my 1st choice of internet browser to use on linux, unfortunately Ubuntu (at least Ubuntu Jaunty 9.04 - server edition) didn't provide mozilla-firefox repository, so we need to install it manually.

Here are the steps to do it:

1. Download the source file from here, choose your preferred version and localized (better take the .tar.bz2 to follow this steps)

2. Installing dependencies
# sudo apt-get install libstdc++5

3. Extracting source files to spesific directory
# sudo tar -C /opt -jxvf firefox-*.tar.bz2

4. Manual install
# cd /opt/firefox/plugins
# sudo ln -s /usr/lib/mozilla-firefox/plugins/* . (there's a dot at the end of the line)
# sudo dpkg-divert --divert /usr/bin/firefox.ubuntu --rename /usr/bin/firefox
# sudo ln -s /opt/firefox/firefox /usr/bin/firefox
# sudo dpkg-divert --divert /usr/bin/mozilla-firefox.ubuntu --rename /usr/bin/mozilla-firefox
# sudo ln -s /opt/firefox/firefox /usr/bin/mozilla-firefox

One addition to this installation is flash plugins
1. Get the source
Go to this page, and choose .tar.gz for Linux

2. Go to Download folder, extract and move to plugins directory
# tar xvfz install_flash_player_10_linux.tar.gz
# mv libflashplayer.so ~/.mozilla/plugins/

And you are done! Just execute your browser by typing "firefox" on your terminal. Enjoy :)

Applications running on my Ubuntu

On my work, I'm using Ubuntu Jaunty (9.04) server edition. As you might already using it, you will know that server edition not equipped (yet) with X server and desktop manager like KDE or GNOME. The reason I choose server edition are it's lite, and I can add only applications that I use. Desktop edition already fill with many applications I don't even use, and it's so heavy for my 256mb RAM!

OK, here are lists of applications I'm using, starting from X server and DM:
execute this first:
# sudo apt-get update
# sudo apt-get upgrade

1. X server and xinit
# sudo apt-get install xserver-xorg xinit xorg

2. WindowManager (either xfce4 or fluxbox, equal lite for me)
# sudo apt-get install xfce4
From this step, you can execute 'startx' to login to your Desktop Manager.

note: this step is optional, you can install any desktop manager you want: Gnome, KDE or anything.. as long as your computer is powerful enough :)

3. Mozilla Thunderbird - email client
# sudo apt-get install mozilla-thunderbird

4. Mozilla Firefox - internet browser
I make a writing about installing firefox here

5. OpenOffice - office suite
# sudo apt-get install openoffice.org

6. Network utility
# sudo apt-get install ssh nmap traceroute tcptraceroute dnsutils

7. CUPS (Common UNIX Printing System)
# sudo aptitude install cupsys

8. Samba - file sharing
# sudo aptitude install samba smbfs smbclient

9. Nautilus - file manager
# sudo apt-get install nautilus

10. File compression tools
# sudo apt-get install rar unrar zip unzip ark

With this 10 applications, I can do everyday office works. How about you? Please share your everyday usage applications on comments :)

Chatopus - alternative IM client for Palm OS

If you still using Palm OS till now, when other OS seems to grow violently :), you should be proud of it, I do. It's been almost 10 years since the first time I use Palm PDA. The last one is Treo 650, and I still keep it till now although my primary phone is Treo Pro which using Windows Mobile.

This time I want to write about one IM applications name Chatopus, perhaps you already know that from long time ago. In the newest version (2.51), it has added integration with Nimbuzz, a mobile social messaging service that allow you to connect to many IM protocol (YM, MSN, Gtalk, Aol) and even Facebook chat :)

It's very simple, just create a new Nimbuzz account, installing Chatopus on your Palm device, then launch it. You'll get this on your device's screen:


Fill in your Nimbuzz username and password, that's it! You're done :) Enjoy, and don't forget to support the developer by purchase. Long live Palm OS!

Wednesday, October 7, 2009

Comparing Treo 650 and Treo Pro, physically :)




bottom view and front view


right-side view and left-side view



back view and top view

Pure-FTPD, an FTP server for linux

This is a simple steps to build your own FTP server in your home/ small office network, with username and password to access it. I run this on my Ubuntu Jaunty (9.04) server edition:

1. Installing the pure-ftpd package:
#sudo apt-get install pure-ftpd

2. Creating new group for FTP users:
#sudo groupadd ftpgroup

3. Creating directory for FTP users:
#sudo mkdir /home/ftpusers

4. Creating directory for each FTP user:
#sudo mkdir /home/ftpusers/joe

5. Creating the user in linux system, include the user in ftpgroup and point the home directory:
#sudo useradd joe -G ftpgroup -N -d /home/ftpusers/joe/

5. Create default password for FTP user:
#sudo passwd joe

And you are done! :)

* This example using "joe", you can create your own username.

Monday, September 28, 2009

Build your own Android-x86 installer image :)

I just make the summary of what I did, you can see yourselft for the complete environment building and building the image.

I'm using Ubuntu 9.04 Server edition, so these steps are for linux:

1. Build your environment
$ sudo apt-get install git-core gnupg sun-java5-jdk flex bison gperf libsdl-dev libesd0-dev libwxgtk2.6-dev build-essential zip curl libncurses5-dev zlib1g-dev valgrind
  • Intrepid (8.10) users may need a newer version of libreadline:
    $ sudo apt-get install lib32readline5-dev
2.  Installing Repo (Repo is a tool that makes it easier to work with Git in the context of Android)
$ curl http://android.git.kernel.org/repo >~/bin/repo
$ chmod a+x ~/bin/repo

3. Get Android-x86 Source Code 
$ mkdir android-x86
$ cd android-x86
$ repo init -u git://git.android-x86.org/platform/manifest.git
$ repo sync

4. Building The Image
For Live CD:
$ make -jX iso_img TARGET_PRODUCT=eeepc

For USB Image
$ make -jX usb_img TARGET_PRODUCT=eeepc

- you can subtitute X with number of core processor you have


Then you will get an iso file out/target/product/eeepc/eeepc.iso, or usb image file out/target/product/eeepc/eeepc_usb.img

Android-x86 on Asus eee PC 701 Series

After successful running Android LiveCD on virtual machine (I'm using VMware Workstation, see my note here), I finally managed to install and run Android x86 on Asus eee PC 701 Series. The ISO installer image I've built using Ubuntu 9.04 Server. Just trying out many applications on it, now :)


Thursday, September 24, 2009

Fun Apps for Windows Mobile (PPC) devices

I just want to share some applications I've used on my Palm Treo Pro (Windows Mobile based). These applications also been used when I still have Palm Treo 750v, of course with slight differences.. since Treo Pro already have Wi-Fi and built-in GPS.

1. BEIKS Dictionary (both Treo Pro and Treo 750v)
A dictionary :)

2. bLADE Locate (Treo Pro only)
An apps to share your location via FireEagle, can automatically update position by GPS and time interval

3. Evernote (both)
Online note-taker, share anywhere between your Windows Mobile phone, Mac, Linux, Windows

4. Garmin Mobile XT (Treo Pro only)
Map tracking application from Garmin

5. Google Maps (both, with limitation on Treo 750v)
Map tracking application from Google, but you better have unlimited data plan if you want to play around with this apps. And you can try Google Latitude as well

6. GPSed (Treo Pro only)
Record your track and upload to web to examine later

7. Microsoft My Phone (both)
Backup your contact, calendar, task, SMS, documents on your Windows Mobile phone, and you just need to install and synchronize everytime you change to another Windows Mobile phone.. and voila, you new phone will have exactly the same data as your old one :)

8. Palringo (both)
All-in-one IM apps in your phone and computer. Very lite, snappy and use less data comparing to another IM apps for Windows Mobile.

9. PockeTwit (both)
For your twitter activity, following, reply, update status. Also integrated with ping.fm

10. Twikini (both)
Alternative to PockeTwit. You can read my review about Twikini, here :)

11. SEVEN (both)
Enabling push mail functionality to your phone. Try it then you'll like it :)

12. Skyfire (both)
Alternative browser for your Windows Mobile phone. New way to present the web page, server-compression and flash support.

13. Spb Wireless Monitor (both)
Very useful to monitor your limited data plan. Also has another feature to export a report, monitor wi-fi usage and or USB connection.

14. GoogleSync (both)
Sync-ing Contact, Calendar and your Gmail. This can be done via ActiveSync, just check the instruction on the website.

Must-use Mac Apps

These are the list of must-use Mac apps (or at least, that I've been using :p) and a little description about the apps:

1. QuickSilver
As it quotes on the websites: "Act without doing", it is a new way to use your Mac. Simple, just trigger it, type any application or file, and execute it. It's a little bit hard to understand this way, so I suggest you to install and try it yourself :)

You can see here for longer explanation and screenshots.

2. Adium
All-in-one Instant Messaging application, you can connect to whatever protocol you've been using (Yahoo!, MSN, Gtalk, Jabber, etc.), and your friend list will appear in one list, so simple. No need to install many applications.

Here are some screenshots.

3. Cyberduck  
FTP, SFTP, WebDAV, Cloud Files & Amazon S3 Browser for Mac OS X.


4. Macports 
If you are also a linux user, then you gonna love this one. It creates environment that enables you to compile, installing and using many linux application under command-line or X11. For this to work, you need X11 and Xcode Developer Tools.

LiveAndroid on my PC

I just successfully running LiveAndroid (v0.3) on my Ubuntu Jaunty (9.04) using VMware Workstation 6.5.3. The experiment so far working well, I got crash when playing the car racing game, though :p But, I like it very much! Can't wait to build it (which I already did several times and failed) for my Asus EEE minipc 701. Here are some screenshots I've taken:


LiveAndroid splash screen


Zoom functionality on browser


Home UI


All Applications


Messaging UI

Wednesday, September 16, 2009

10 Best Low Radiation Phone

According to Environmental Working Group (EWG), here is the 10 Best Low Radiation Phone. You can also take a look at full list to find out about your phone here

VMware Server 2 on Ubuntu Server 9.04

Recently, I was trying to install VMware Server 2 on my Ubuntu Server 9.04 (Jaunty) which using GNOME. The Installation is quite easy, I don't find any problem in each steps. The only problem is I can't create any virtual machine till now (apparently, I need to restarting VMware services to get this VMware Server to work) :p You can try this steps to, at least, gain successful installation:

1. Download your VMware Server installation files from here
You have to create an account if you haven't got one, then you'll have the registration number (for free!) from there :) I suggest you download the tar.gz package for installation on Linux.

2. Preparing your OS environment
a. necessary packages:
#sudo aptitude install linux-headers-`uname -r` build-essential xinetd

b. unpack and install, go to directory where you save the downloaded file
#tar xvfz VMware-server-*.tar.gz
#cd vmware-server-distrib
#sudo ./vmware-install.pl

You can always accept each questions on installation in progress, with default answer they provide or change it with your own preferences.

Enter your 20 digits registration number (you get it from the link in your email after registration), and you're done!

3. Delete installation files and folders
#rm -f VMware-server*
#rm -fr vmware-server-distrib/

4. Password for root
#sudo passwd root

5. Accessing your VMware Server installation
Open your browser, then enter this on address bar:
http://localhost:8222 (http access) or
https://localhost:8333 (https access)

Then login using your root and password





The interface is similar like VMware Workstation (if you ever use it), so I guess it's not a big deal to use the feature on it.



Well, that's it, enjoy.. and I hope you can use it for greater good :)

Saturday, September 12, 2009

PowerBook G4

I am a long user of Windows OS (at home) and various distro of Linux (at office). While looking for a notebook as a mobile device, I found out that my wife's PowerBook G4 quite interesting. Powered with Leopard Mac OS X 10.5.8, I realize that this device has a gorgeous look (very very intuitive UI) and powerful inside (I talk about the kernel, which is BSD-based kernel). Anyone who is familiar with Linux, will fastly adapt to work using the Terminal. The CLI included is almost as complete as the linux's tools I'm using at office. And if that's not enough, I can add and customize yourself using MacPorts. Equipped with this Terminal, I can do my works as an engineer flawlessly. And I have the benefit of using the beautiful and simple UI when I want to use it to develop a website.

The only drawback I found, this PowerBook G4 is not using Intel Processor (yet!). This is, only a little, bothering me when I want to run .exe (32bit windows application) files. But, I can live with that (at least for now) :D

I'll back to you, with reviews of any mac apps that I've been using. Stay put! :)


Androkkid - Android-like UI for Windows Mobile devices

Recently, I've been installing and playing around with Androkkid - Android-like UI for Windows mobile devices. Although still in early beta (version 0.4.0), but it quite good. Installing it on my Palm®Treo™Pro which have square screen (320x320), Androkkid runs very smooth using my thumb or my nails to slide between screens. And I guess it also runs good on all other Windows Mobile devices that have different screen resolutions.

You can download and try it from the developers site, which also provide additional wide wallpapers and icons. I like it, and I want to play a little more with this Androkkid, while waiting any improvement between versions upgrade.

Just try it, and don't forget to donate the developers if you like it :)



Wednesday, July 8, 2009

Samsung SGH-i617 BlackJack II








Saturday, June 6, 2009

Twikini - lightest twitter client for Windows Mobile


I've been a twitter user for a while now. At first I only following updates and posting from my web browser at office's computer. Gradually I added the persons I follow and my followers increased as well. So, I need more time, periodically checking my twitter to posting update and replying post from my colleague.

Since I'm using Samsung BlackJack™ II with Windows Mobile Smartphone OS, I tried several application while comparing each of them, which one is suitable for me. Then, from one of twitter posting, I found out about Twikini, brand new twitter client. It says that this apps is the lightest twitter client for Windows Mobile. So, I download and try it.

And, apparently that statement is true. This Twikini is very light, the most I guess, comparing to other clients I've tried before. Beside BlackJack™ II, I also installed in my Treo™ 750 which based on Windows Mobile OS, too.

So, what've you waiting for? Go directly to http://www.trinketsoftware.com/Twikini and try it your own :)

GPSed - Tracking application for Windows Mobile

If your phone (iPhone, BlackBerry, Windows Mobile or J2ME) has internal GPS receiver, you could try this awesome application called Gpsed. For me, it had help me a lot, I could track back every path I've been pass through.

All you need to do is:
1. Go to their website
2. Register to get free account
3. Download the client for your phone
4. Setting up social networking you want to share to (facebook, twitter, myspace and blogger)
5. Start recording track

It will then run on background. And when you arrive at destination, you just finish the recording. You'll be asked if you want to upload the track to gpsed.com and to social networking site you've setup before. Then You'll get this (below) in your social networking site:

View my new track "kemayoran - manggala via tol" started in Indonesia, Daerah Khusus Ibukota Jakarta Raya, Jakarta.
Powered by GPSed.com - Free Mobile GPS Tracking Service

Friday, May 29, 2009

GPSed Track "manggala - tkc via sudirman"


View my new track "manggala - tkc via sudirman" started in Indonesia, Daerah Khusus Ibukota Jakarta Raya, Jakarta.

Powered by GPSed.com - Free Mobile GPS Tracking Service



Thursday, April 23, 2009

Installing snmpd

1. # sudo apt-get install snmpd
2. # sudo cp /etc/snmp/snmpd.conf /etc/snmp/snmpd.conf.bak
3. # snmpconf

-- a. Read in which: choose ALL (default) for configuration file
-- b. Select file to create: snmpd.conf
-- c. Choose 1: Trap Destinations
-- d. Choose 1: A SNMPv1 trap receiver
-- -- host name that should receive the trap: localhost [or any server in your network]
-- -- the community to be used in the trap sent: public [or whatever you want]
-- -- the port number the trap should be sent to: 161 [most used]
-- -- then type: finished
-- e. Choose 6: Access Control Setup
-- f. Choose 3: a SNMPv1/SNMPv2c read-only access community name or
-- 4: a SNMPv1/SNMPv2c read-write access community name
-- -- the community name to add read-only access for: public
-- -- the hostname or network address to accept this community name from [RETURN for all]: RETURN
-- -- the OID that this community should be restricted to [RETURN for no-restriction]: RETURN
-- -- then type: finished
-- g. finished

4. # sudo cp /etc/snmp/snmpd.conf /usr/share/snmp/snmpd.conf
5. # sudo vi /etc/default/snmpd

Change from:

# snmpd options (use syslog, close stdin/out/err).
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'

To:

# snmpd options (use syslog, close stdin/out/err).
# SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid 127.0.0.1'
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -I -smux -p /var/run/snmpd.pid -c /etc/snmp/snmpd.conf'

6. restart snmpd:
# /etc/init.d/snmpd restart

7. try your snmp:
# snmpwalk -v [snmp version] -c [snmp community name] [host] -O a

if you receive any reply, then you done it! :)

Improving Font On Linux

Although this documentation specifically created for Ubuntu Linux, I have tried this method with both Ubuntu and Gentoo. The difference only on package (portage on Gentoo) and where the system put font files.

Fonts you need: artwiz-aleczapka, ttf-bitstream-vera and corefonts


1. artwiz-aleczapka and ttf-bitstream-vera
just Google these 2 fonts, and download it, then:
# tar xvjf artwiz-*.tar.bz2
# sudo mv artwiz-* /usr/share/fonts/X11/misc

# sudo dpkg -i ttf-bitstream-vera*.deb

2. corefonts
luckily, the corefonts package already available from ubuntu default repository, just execute:
# sudo apt-get install msttcorefonts

After done with all three fonts, run this:
# sudo fc-cache -f -v
# sudo dpkg-reconfigure fontconfig
# sudo dpkg-reconfigure fontconfig-config, and follow this options:
-- 1. native
-- 2. automatic
-- 3. yes

And you can add it to your /etc/X11/xorg.conf file (I put adding line in bold):

Section "Files"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera/"
FontPath "/usr/share/fonts/truetype/msttcorefonts/"
End Section

Upgrading Treo 750v to WM 6.1

Please do it at your own risk!

Upgrading to WM 6.1 will give you more snappy and powerful Treo 750v (at least that's what I felt :D ), especially with newer version of Mobile Office that have capabilities to open Microsoft Office version 2007 files. You feel it yourself later on :)

Nevertheless, you will loose Remote Desktop Client, Voice Command and Windows Live, because this WM 6.1 ROM is made to be thin.

What you need is blank miniSD (real one, not microSD with adapter), formatted with FAT32 (you can use card reader and format it from your PC):


1. Make sure you have this 3 file (I will add the link later):
a. CheetahUnlocker.rar
b. Treo750_OS5_2_19199WWE_STD.rar
c. Treo750Radio1.54.07.00.rar

2. Before running CheetahUnlocker, make sure you already:
a. Install Microsoft .NET Framework version 2.0 (http://bit.ly/16b0b6)
b. Close all other program (especially Anti Virus and Firewall) to avoid any disruption.
c. Plugin your USB cable and ActiveSync/ WMDC run smoothly

3. On CheetahUnlocker, just run Step 1 if your Treo already unlocked. Make sure it running smoothly and your Treo can do normal boot.

4. Prepare your already-formatted FAT32 miniSD, copy CHEEIMG.nbh (radio), put it in slot. While press and hold PTT (the one below up-down volume button), press "reset" button. Wait until the screen display "SUCCESS..."

5. After that, copy CHEEIMG.nbh (OS) to miniSD, put it in slot. And do the press-hold PTT and press "reset" button again. Wait till "SUCCESS..." appear.

6. Do soft reset!

7. Enjoy your more snappy and powerful Treo 750v :)

CLI Networking Tools on Windows XP

1. ARP: display and modifies the IP-to-Physical address translation table used by ARP
parameter: ARP -s inet_addr eth_addr [if_addr]
ARP -d inet_addr [if_addr]
ARP -a [inet_addr] [-N if_addr]

2. Netstat: display protocol statistic and current TCP/IP networking connection
parameter: netstat [-a] [-b] [-e] [-n] [-o] [-p proto] [-r] [-s] [-v] [interval]

3. Route: manipulates network routing tables
parameter: route [-f] [-p] [command[dest][MASK netmask][gateway]
[METRIC metric][IF interface]

command: PRINT ADD DELETE CHANGE

4. Net User: create and modifies user accounts (only on server)
parameter: net user
[username[password|*][options]][/DOMAIN]
username{password|*}/ADD[optons][/DOMAIN]
username[/DELETE][/DOMAIN]

5. Ipconfig: display IP addr, subnet mask, default gateway for each adapter bound to TCP/IP
parameter: ipconfig [/?|/all|/renew[adapter]|/release[adapter]|
/flushdns|/displaydns|/registerdns|
/showclassid adapter|
/setclassid adapter [classid]]


6. Nbtstat: display protocol statistics & current TCP/IP connection using NBT (netBIOS over TCP/IP)
parameter: nbtstat [[-a RemoteName][-A IP addr][-C][-n][-r][-R][-RR][-s][-S][interval]]

7. Tracert
parameter: tracert [-d][-h max_hops][-j host-list][-w timeout] target

8. Ping
parameter: ping [-t][-a][-n count][-l size][-f][-i TTL][-v TOS]
[-r count][-s count][[-j host-list]|[-K host-list]][-w timeout] target

9. Telnet
parameter: telnet [-a][-e escape char][-f logfile][-l user][-t term][host[port]]

10. Netsh: interactive CLI utility, allow you to list & change network layer

11. Nslookup: tools for query DNS
> set type=any/mx/ns
> server [name]|[IP]

12. Pathping: combine ping and tracert
parameter: pathping [-g host-list][-h max_hops][-i addr][-n][-p period]
[-q num_queries][-w timeout]
[-P][-R][-T][-4][-6] target

Thursday, April 16, 2009

SSMTP - sending email from terminal

I just installing this application to sent email from command line/ terminal, it's call ssmtp. For ubuntu/ debian distro, you can trigger this command:
# sudo apt-get install ssmtp

After that you can edit /etc/ssmtp/ssmtp.conf:
AuthUser=[email address]
AuthPass=[email password]
FromLineOvveride=YES
mailhub=[smtp server]:[port]
UseSTARTTLS=YES

And you can test it by typing this simple script:
$ echo "This is a test" | ssmtp -s "Test" [destination email address]

Wednesday, April 15, 2009

WM 6.5 for Treo 750

About two weeks ago, I had a chance to injecting Windows Mobile 6.5 (cooked ROM) to my old phone Palm Treo 750v :) Although it says that the specification of Palm Treo 750v is not qualified for this new OS from Microsoft, I just can't hold on to the temptation to see much more new features offered by it.

After a short time of trial, I decided to go back to Windows Mobile 6.1 (also a cooked ROM). It is not that I don't like WM 6.5, but it's more that this cooked ROM doesn't fit well to Palm device. It just lost all the simplicity and features that Palm devices have (I feel it when using my Palm Treo with WM 5.0, WM 6.0 and now WM 6.1). The major problem is I cannot use my Palm Treo without stylus on WM 6.5, I have to pull out my stylus everytime. That's never happened on WM 5.0 to 6.1 :D

Honestly, new Home UI, hexagon-like (without grid line) Program list, and excited feeling that my old gadget was able injected with this brand new OS is so great! Of course I'm still waiting that this cooked ROM will be available to be compatible with Palm device especially Palm Treo 750 :D Can't wait!

*For references and download this cooked ROM, you can go here

Saturday, January 24, 2009

Basic Cisco Router settings for LC connection

Here is how-to configure (most) Cisco Routers for Leased-Line connection:
> enable
# configure terminal
# interface Serial 0/0
# description [write description for current interface] => usually "Connected to ISP"
# ip address [IP] [subnet mask]
# no shutdown => enable current interface

# interface FastEthernet 0/0
# description [write description for current interface] => usually "Connected to LAN"
# ip address [IP] [subnet mask]
# no shutdown => enable current interface
# exit

# ip name-server [DNS1] [DNS2] .. [DNS 5] => up to 5 DNS
# ip route [destination network] [subnet mask] [host]
# exit

after that, you can check your configuration by typing this command:
# show running-config

don't forget to save it:
# write

and it's done! :-)

Friday, January 16, 2009

setting Gmail di Versamail

Saya coba buatkan guide sederhana dengan sedikit screenshot:

1. Di dalam VersaMail, klik Accounts -> Accounts Setup











2. Beri nama apa saja, pilih Other untuk mail service dan protocol: POP








3. masukkan username (lengkap dengan @gmail.com) anda: [username]@gmail.com dan password anda









4. masukkan email address dan parameter pop-smtp







5. klik Advanced dan masukkan setting untuk incoming server, port: 995 dan hanya option ‘Use Secure Connection (SSL)’ saja







6. Lalu next, dan masukkan setting untuk outgoing server, port: 587 (saya setting beberapa versamail, kebanyakan bias jalan di port 587 ini) dan kedua buah option diberi checkmark semua, lalu masukkan username: [username]@gmail.com







Itu saja settingan Gmail di VersaMail. Selamat mencoba, semoga berhasil!